AlgoBox : fonctions_algo22
Tester l'algorithme
Cliquer sur ce bouton pour exécuter l'algorithme : 

Résultats

Code de l'algorithme
1   VARIABLES
2     a EST_DU_TYPE NOMBRE
3     b EST_DU_TYPE NOMBRE
4     m EST_DU_TYPE NOMBRE
5     p EST_DU_TYPE NOMBRE
6   DEBUT_ALGORITHME
7     a PREND_LA_VALEUR 1
8     b PREND_LA_VALEUR 2
9     LIRE p
10    TANT_QUE ((b-a)>p) FAIRE
11      DEBUT_TANT_QUE
12      m PREND_LA_VALEUR (a+b)/2
13      SI (pow(m,2)<3) ALORS
14        DEBUT_SI
15        a PREND_LA_VALEUR m
16        FIN_SI
17        SINON
18          DEBUT_SINON
19          b PREND_LA_VALEUR m
20          FIN_SINON
21      FIN_TANT_QUE
22    AFFICHER a
23    AFFICHER b
24  FIN_ALGORITHME