- Algorithme -  L’instruction conditionnelle -

Définition :
La résolution des certains problèmes nécessite la mise en place d’un test pour savoir si l’on doit effectuer une tâche.
Si la condition est remplie alors on effectue la tâche,
sinon on effectue (éventuellement) une autre tâche.

Dans un algorithme, on code la structure du « Si... Alors.. Sinon » sous la forme suivante :

Si condition
Alors
Tâche 1
Tâche 2
...
Sinon
Tâche 1bis
Tâche 2bis
...
Fin Si

Définition :

Une condition est une expression qui peut prendre l'une des deux valeurs suivantes vrai ou faux. On dit également que c'est une valeur de type "logique" ou "booléen".

Les principaux opérateurs de comparaison que vous rencontrerez sont les suivants :
  • égal à ( == )
  • différent de ( != ou <> )
  • strictement supérieur ( > )
  • strictement inférieur ( < )
  • supérieur ou égal ( >= )
  • inférieur ou égal ( <= )
Ces comparaisons n'ont un sens que si les variables que l'on compare sont de même type.



Remarques :
1 ) Il est important de respecter les espaces laissés au début de chaque ligne, car ils permettent une meilleure lisibilité de l’algorithme.
2 ) Le « Sinon » n’est pas obligatoire. S’il n’est pas présent, aucune tâche ne sera effectué si la condition n’est pas remplie.

Exemples :
1 ) L’algorithme 2 permet de déterminer si un triangle ABC est rectangle en C.
2 ) L’algorithme 3 est un exemple d’algorithme calculant l’image d’un réel x par la fonction définie par f(x)=(x+5)/(x-7) en respectant son ensemble de définition.
3 ) L’algorithme 4 simule un jeu de pile ou face avec une pièce non truquée. « Pile » est représenté par le nombre 0 et « Face » par le nombre 1.

Programmation
Algorithme 2

Triangle rectangle en C
Exécuter

Lire AB
Lire AC
Lire BC
 AB^2
 AC^2+BC^2
Si (x==y) Alors
  Afficher « Le triangle ABC est rectangle en C »
FinSi
Sinon
  Afficher « Le triangle ABC n’est pas rectangle en C »
FinSinon 

Programmation
Algorithme 3

Image par une fonction en tenant compte de l’ensemble de définition
Exécuter

Lire x
Si (x!=7) Alors
  y (x + 5) / (x − 7)
  Afficher y
FinSi
Sinon
  Afficher « La valeur choisie n’est pas dans l’ensemble de définition »
FinSinon 

Programmation
Algorithme 4

Jeu de Pile ou Face
Exécuter

Lire choix
tirage  nombre au hasard choisit dans l’ensemble {0 ; 1}
Si (choix == tirage) Alors
  Afficher « Gagné ! »
FinSi
Sinon
  Afficher « Perdu ! »
FinSinon 

Exercices

 

Ex 8 :

On considère l’algorithme ci-dessous :

Lire X ( X est un entier )

Si (X est un multiple de 9) Alors

   Y ← X/9

FinSi
Sinon

   Y ← X-9
Fin Sinon

Afficher Y

 

1 ) Qu’affiche cet algorithme en sortie pour les valeurs suivantes de la la variable X ?

a ) X=27 b ) X=3339 c ) X=2345 d ) X=666

2 ) Traduire cet algorithme en Python.

Ex 9 :

Un groupe de personnes souhaite réserver un chalet pour les sports d’hiver. Le prix de la location à la semaine est 700 euros. Le forfait pour skier est de de 210 euros par personne . Il existe aussi un tarif de groupe à 170 euros par personne à partir de 5 personnes d’un même groupe.

1 ) Compléter l’algorithme ci-dessous, afin qu’il affiche en sortie le prix payé par le groupe pour la semaine, suivant le nombre de personnes du groupe saisi en entrée.

Lire N ( N est un entier )

Si ( …              ) alors
–--P ← ...

FinSi
Sinon
     P ← 700+210*N
FinSinon

Afficher P

2 ) Modifier cet algorithme afin qu’il affiche en sortie le prix que doit payer chaque membre du groupe.

3 ) Traduire cet algorithme en Python.

 

 

 

Programmation
correction de l'ex 8 :
Exécuter



 

Site et contenu réalisés par Pierre Lux - professeur de mathématiques au Lycée Lyautey de Casablanca
Site construit avec le logiciel Gest'classe
 
 
Gest'classe © 2016 créé par Lux Pierre - Télécharger Gest'classe